你们的2.3用php8.3能发布内容吗?

hxuf5202024-03-13  630

火车头php8.3不能发布内容。php8.2是正常的。

如果一定要使用8.3该改哪里?

转载请注明原文地址:http://www.wellcms.net/read-761.html
00
最新回复(2)
  • 8.3也正常
    回复00
  • 支持 PHP 8.3,用支持 utf8 的编辑器打开 index.php 文件,找到

    !defined('DEBUG') AND define('DEBUG', 0);


    将 DEBUG 的值修改为 2

    !defined('DEBUG') AND define('DEBUG', 2);

    然后测试,再到 log 目录查看错误文件。

    没有必要追求高版本,高版本也是牺牲内存换性能,而 wellcms 的设计架构决定了,即使是PHP7.2 也不会比 8 以上的版本差多少。

    如果不会设计业务逻辑、不懂IO、不懂数据库、不懂缓存,只是会写代码的程序员,那么应该使用高版本的数据库和 PHP 更高版本。

    对于 wellcms 来说 MySQL 5.5.6 + PHP 7.2 + OPcache + Yac/Redis/Memcached任意一个缓存,区跟高版本的数据库和PHP对比,不会有非常明显的差距。

    回复00